Skip to main content

Downgrade from Aerospike Database version 5.5 or newer to version 5.4 or version 5.3 or version 5.2

Downgrading from Aerospike Database version 5.5 or newer to version 5.4 or version 5.3 or version 5.2 (where XDR bin convergence has been used).

On an Aerospike Database version 5.5 or newer node, if the bin convergence feature has been used, extra bin metadata may have been generated and stored within records. When migrating such records to Aerospike Database version 5.4 or 5.3 or 5.2 nodes during a downgrade, the older nodes will not be able to read these records.

If downgrading to 5.4, before downgrading, dynamically set downgrading to 'true' on every node.

If downgrading to 5.3 or 5.2, before downgrading, dynamically unset convergence-related configurations and set downgrading to 'true' on every node.

When restarting a node with a version previous to 5.5, the drives must be wiped in order to remove unreadable records.